문제

그래프를 DFS로 탐색한 결과와 BFS로 탐색한 결과를 출력하는 프로그램을 작성하시오. 단, 방문할 수 있는 정점이 여러 개인 경우에는 정점 번호가 작은 것을 먼저 방문하고, 더 이상 방문할 수 있는 점이 없는 경우 종료한다. 정점 번호는 1번부터 N번까지이다.

입력

첫째 줄에 정점의 개수 N(1 ≤ N ≤ 1,000), 간선의 개수 M(1 ≤ M ≤ 10,000), 탐색을 시작할 정점의 번호 V가 주어진다. 다음 M개의 줄에는 간선이 연결하는 두 정점의 번호가 주어진다. 어떤 두 정점 사이에 여러 개의 간선이 있을 수 있다. 입력으로 주어지는 간선은 양방향이다.

출력

첫째 줄에 DFS를 수행한 결과를, 그 다음 줄에는 BFS를 수행한 결과를 출력한다. V부터 방문된 점을 순서대로 출력하면 된다.

예제 입력 1

1
2
3
4
5
6
4 5 1
1 2
1 3
1 4
2 4
3 4

예제 출력 1

1
2
1 2 4 3
1 2 3 4

예제 입력 2

1
2
3
4
5
6
5 5 3
5 4
5 2
1 2
3 4
3 1

예제 출력 2

1
2
3 1 2 5 4
3 1 4 2 5

예제 입력 3

1
2
1000 1 1000
999 1000

예제 출력 3

1
2
1000 999
1000 999

내가 푼 코드

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
import java.util.*;

public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int n = sc.nextInt(); //정점의 개수
int m = sc.nextInt(); //간선의 개수
int v = sc.nextInt(); //탐색 시작 번호

ArrayList<Integer>[] a = (ArrayList<Integer>[]) new ArrayList[n+1];
for(int i=1; i<=n; i++) {
a[i] = new ArrayList<Integer>();
}
//간선 갯수만큼 인접 리스트 채우기
for (int i=0; i<m; i++) {
int o = sc.nextInt();
int u = sc.nextInt();
a[o].add(u);
a[u].add(o);
}

//check:0 방문한적 없음 , check:1 1번그룹
int[] check = new int[n+1];

//방문한적(check)이 없을 경우
if(check[v] == 0) {
dfs(a, check, v);
}
System.out.println();

//체크 배열 초기화
check = new int[n+1];

//방문한적(check)이 없을 경우
if(check[v] == 0) {
bfs(a, check, v);
}

}
public static void dfs(ArrayList<Integer>[] a, int[] c, int v) {
Collections.sort(a[v]);
if(c[v] != 0) return;
c[v] = 1;
System.out.print(v + " ");
for(int x : a[v]) {
if(c[x] == 0) {
dfs(a, c, x);
}
}
}

public static void bfs(ArrayList<Integer>[] a, int[] c, int n) {
Queue<Integer> q = new LinkedList<Integer>();
q.add(n);
c[n] = 1;
// queue가 비어있을 때 까지
while(!q.isEmpty()) {
int x = q.remove();
System.out.print(x + " ");
for(int y: a[x]) {
if(c[y] == 0) {
q.add(y);
c[y] = 1;
}
}
}

}

}